Behringer UMC 404 HD troubles

Hello everyone,

Some of you have already heard my complaints a little bit ago on the last livestream (17th of may). Anyway, I’ve had the Behringer UMC 404 HD for a little while now, however I’ve had a fair amount of pops and crackles. After doing some googeling, it seems like it’s an buffer starvation issue.
I’ll start with an overview of my system.:

OS: Windows 10 Professional
CPU: Ryzen 2400G APU (4c8t)
GPU: Radeon RX Vega 11 graphics
MOBO: Asrock AB350M Pro4
Ram: 2x 8GB Ballistrix Sport DDR4 3200 MHZ

As for my current audio settings, I’ll write them down and include some screenshots.
Bitrate: 24 bits
Sample rate: 192Khz
Buffer size: 8192 Samples

Note: Because I’m a new user I can only post one picture, will update with more once I become a normal user
image
image
image
image
image
image
image

All other in and outputs have the same settings as out 1-2 properties.

So, even after changing the settings a bunch of times, with sample rates from 44.1Khz trough 192Khz, and buffer sizes from 8 to 8192 samples, I still get pops and crackles.
The UMC404HD is connected to a usb 2.0 port, and changing it to another port (3.0 or otherwise) didn’t change anything.
Changing the buffer size did change the amount of pops and crackles, where a smaller buffer size generally caused more pops and crackles.
What’s quite interesting is that at a higher sample rate (i.e. 192Khz instead of 44.1Khz) the pops where of a audibly higher frequency.

I’ve also tried the interface on a couple of other systems. On my linux laptop it had a bunch of pops and crackles as well. There however, I suspect it was CPU bound, as it’s a very old laptop (2GB of ddr2 and an intel core centrino duo) with limited cpu power. Finally I also tried it with my phone (Cubot Quest) through the USB C OTG port on there with a little adapter. To my surprise this worked perfectly.

I would record what they sound like, but for that I would have to solder up a weird connector right now, and I don’t know how this interface responds to chaining it’s outputs directly to itself. If anyone’s very interested in the way it sounds, I can record it on my phone later. It should be audible enough for that.

If anyone has any idea for what I could do to improve the situation, that would be great. I will update this main post with things that I’ve tried, and if there’s something that definitively fixes it.

-Foorje

Edit 1:
I’ve made some sample recordings of the pops at different sample rates and buffer settings, here’s a link:
https://drive.google.com/open?id=1BBVLRjm_WE_pB1tykdDOU0OjoR0TFa0d

4 Likes

I do not have a lot of knowledge on windows systems, but I know that in windows XP era the buffering done by the OS (apart from what the audio device does) could cause problems. You might wat to look into this. I’ve got the same interface but use it on OSX without any problems.

3 Likes

Lets start by you dropping that sample rate to 44100Hz with 24-bit depth, and use an ASIO buffer Size of 512 samples.
ASIO will not be active when you are running day to day, only when its called upon.

5 Likes

That latency looks pretty high. I also wonder if it makes much difference that your latency is greater than your buffer size.

Here’s a possible fix I found online. See if it works for you.

3 Likes

The latency is high because the number of buffer samples is high. I assume they were increasing it because pops like these are usually fixed with additional sampling. 512 should be more than enough though.

Mine for reference:
image

I can increase to a higher sample rate though, is im not even sure thats the issue of course. just asking so we can align to be as similar as possible before troublshooting.

Also, just to keep things nice and simple, please keep using the USB 3.0 to avoid other bottleneck behaviors from cropping up. You said you didn’t notice a diff, but that will for sure matter even if its not the current issue. -edit- This cant be a problem, looking over the specification it seems the port on the interface is simply 2.0 anyways.

Also, @foorje, im sure we are going to cover plenty of things you have already tried, this is just to cover everything when troubleshooting.

Can you share the driver version you are working with (in the about tab)

image

Try this:


In audacity, you can configure the input to be the output. This will record whatever sound is coming from the outputs of the interface.

3 Likes

Same problems. Tried to fix it for months. Decided to buy another interface. Apparently it’s a bitrate conflict. I could let it stop, by changing the bitrate (or just going into the control panel and reselecting the bitrate) and after x amount of time it started crackling again… So it was kind of workable, but than I had a performance (theatre) and it started doing it in the middle of the performance. It just wasn’t acceptable to me. It also shouldn’t be this cumbersome. Maybe there’s a solution, but I gave up. Not to sound discouraging. This was just my experience with the same problem. Now I never have those problems.

Edit: So I think it receives another bitrate from somewhere and then it goes nuts. I just don’t know where it was coming from.

1 Like

I’ve tried around a bit, and it seems that I can’t record the pops and crackles by directly recording the output, so I’ve used a microphone to record it instead.

Here’s the best i can currently get it (192Khz sample rate 440Hz test tone):
image

Same sample rate, different buffer settings (512 samples, safe mode on)


As you can hear, this has significantly more pops.

44.1Khz buffer of 512 samples

For completionists sake I’ll also run 44.1Khz on the highest and lowest sample rate.
44.1Khz buffer 8 samples


44.1Khz buffer 2048 samples

And finally a folder with all of the samples recorded thusfar
https://drive.google.com/open?id=1BBVLRjm_WE_pB1tykdDOU0OjoR0TFa0d

If this makes you any the wiser i’d love to hear it.

@Bitnik The problem isn’t the latency. Considering that this interface has built in monitoring, I don’t really give a damn about any input latency. The problem is that it pops and crackles a bunch.
Thanks for the advice anyways.

@Jokke Very interesting. I can clearly hear the audio interface connecting and disconnecting after I change the sample rate (for all the inputs and outputs) in windows sound panel. However this doens’t omit the pops and crackles, not even for a little while.

I also think that this is pretty strange, as windows, UMC Control panel, and audacity (in this case) all display the same sample rate. And even with just one application open it still pops and crackles.

1 Like

Thats definitely gapping popcorn pops.

I find it interesting that you cannot recreate the pops when you record the audio out though. Can you hear it if you plug headphones into the monitor jack?

Oh, and please provide your current driver version in the about tab.

My next line of thinking is to eliminate other physical issues like a bad cable or something loose. I am also curious what all you have hooked up to the interface and where, and what else you have hooked up to your machine. There could be interference. Our focus should be to eliminate stages that are before your OS and any software, as i do not have those issues and it seems we have a very similar setup, albeit mine is older/less capable.

The pops you hear when you change bitrate is normal, but you probably know that.

Please record using the outputs as the input as i suggested, even if there isnt any pops i would still like to confirm.

1 Like

Right the current driver, here’s a screenshot:
image

Yeah, it’s on all of the outputs on the back (main, 1-2 and 3-4) and the headphone monitoring output (which monitors the “main” output anyway)

Seems curious that it would be this. Besides a mouse and keyboard I don’t have any peripherals connected normally. The usb cable is the one behringer supplied, and if I use another one the same problem occurs.

Edit:
You just added some more things to your reply so:

Here’s a link for a directly recorded output


And here’s one for the project file

That clean output tells me that the pops should be introduced after that part of the signal chain. You shouldn’t get a clean sound if it were just buffer issues.

Out of curiosity, are you plugging the interface up to a front panel USB, or ones directly in your MB?

What is currently hooked up to your outputs of the interface? This is important, because you said that you hear the pops in the monitor as well as all the outputs.

1 Like

I’ve only got usb 3.0 ports on the front, and some 2.0 in the back, and i’m connected to some 2.0 ports in the back.

Currently there’s just a Denon amplifier connected to the tulip 1-2 outputs on the back.


The mobo you listed shows usb 3.0 in the back. Wanted to eliminate janky computer case USB connections.

Have you the ability to test without the amplifier? Any other headsets or even cheapo pc speakers?

2 Likes

This is some pro level troubleshooting. Am I weird for thoroughly enjoying that? Also, have you tried turning it off and back on? :joy:

4 Likes

Im just sure that @foorje wants to use their interface. Ive been there, and it sucks. Im just here to bounce ideas off of. I just find it an interesting problem since ive not had any issues with mine.

2 Likes

What i said was unclear. What I meant was that there’s purely USB 3.0 in the front (on my case) and both usb 2.0 and 3.0 on the back.

Anyway, I’ve tested with just some headphones, after disconnecting and reconnecting the interface. And I’ve tested the other sets of ports (both front and back) Similar results around the board.
It seemed unlikely that the amplifier would’ve made a difference anyway, as the headphone monitoring is directly connected to the outputs inside of the interface iirc.

Haha, you’re right. But considering how vague everything is acting, I have 3 main suspects as of the moment.
1: Windows OS being windows and doing weird incompatibility things
2: My motherboard being weird and incompatible
3: The behringer unit actually being defective

I would have to agree there. Woulda been nice if you could narrow it down though. Behringer themselves have a 3 year warranty on that thing so maybe try your luck with them!

Yeah i’ll see what submitting a ticket about it to the peeps behind behringer does.
On the bright side, this whole troubleshooting is a great starting point for them too.

2 Likes

I think you should mention that part with the recording the out directly and the pops not being present. This could indicate something wrong with some component. (try wiggling the cables to see if something is loose maybe?)

2 Likes

Good idea. I think i’ll link them to this thread in general anyway.

1 Like

Small update, today I’m having a lot fewer pops than normal. Running 2048 samples at 192Khz (equal to 512 at 48Khz). What’s more interesting is that I can pretty clearly hear that it’s mostly a problem when I’m just playing sine waves.
This might just be confirmation bias though, as the pops are of course a lot more audible when playing a pure sine.

What do you think @Caustic, would this just indicate a defect in the interface or something else?

Furthermore, when playing a lower note the pops and crackles are of a lower frequency as well. To me this would indicate that it would be less of a buffer starvation problem and more of a hardware problem, as buffer starvation pops should be independent of the input.

1 Like