Stumped - Troubleshooting power issues on Yusynth Quadrature LFO

Hi all,
I just finished building a Yusynth Quadrature LFO:
http://yusynth.net/Modular/EN/QUAD-LFO/index.html
And upon my first power up, I promptly smoked the two protection resistors, R1 and R2 (10 ohm). A couple of lights lit up for a moment, but I promptly unplugged when I saw the magic smoke. I can’t, for the life of me, figure out what’s wrong with this circuit. I quadruple checked that the power rails are not shorted to each other, or ground. I’m positive the power header is not reversed.

I quadruple checked that the polarized components and IC’s are in the correct orientation. Double checked my offboard wiring - I’m at a loss.

My understanding is that this kind of thing would happen when the circuit is pulling way more current than it is supposed to for some reason. Has anyone ever seen this before, or know of common causes? Google searches have not been very fruitful. Thanks a million for any insight you can offer, friends!




2 Likes

Sorry to hear of the trouble.

When you say you have checked no shorts on the power rails, have you checked this after the 10ohm resistors? what resistances are you measuring between the rails and ground, and the resistance between +12 and -12.

I would remove the Ics, and check for power on the correct pins. This will also prove an additional check the power header is in the correct orientation. If this has been reversed at any time I would replace the IC’s

Looking at your pcb, you appear to be missing some links, one to the middle of the board, by the 10ohm resistors, and one by the output level pot connector, and two by the lm13700, the board is not an exact match for the image in your link to the module, and I cant tell from the photo if these are connected.

The LM13700 is very sensitive to static on pins 1 & 16, so it is possible this has not been handled correctly.

There is also another post on the forum giving tips for fault finding, but I am late for work, so maybe someone else can post the link.

5 Likes

this one :slight_smile:

4 Likes

Im not sure for this exact module but i had a similar issue, as far as im aware i think those are current protection resistors or whatever. I had a module go up in smoke as i had a dodgy chip which was causing a 5volt regulator to pull alot of current causing the resistors to burn. All i can suggest is check your chips and make sure none are getting too hot. An unadviseable method is change the 10ohms for a higher wattage and see what gets hot.
I wish you luck :))

4 Likes

I don’t know this module, but is it normal that’s some empty holes and also 2 GND holes with no solder too ?

and yes the 2 resistors of 10 ohm are there to “burn” in the event of a short circuit, to protect the rest of the module

4 Likes

In Usson’s single sided design there were links you had to install, and in the Soundtronics description they say it’s two sided and the links aren’t needed, but then why do they have through hole footprints for the links? Seems strange. As for the empty ground pads that’s two of three used for wiring the jacks and I’d assume @WesleyV just used one for all of them.

Even if the absent links are supposed to be present it’d surprise me if they were the cause of this. If both resistors burned out I can imagine no possibility other than two: Reversed power voltage, or a short (or at least a low resistance connection) between the rails. @WesleyV, you say you quadruple checked both, but I can’t see how it could be anything else, so let’s think about whether your checks really covered everything.

The power header is oriented correctly, so reversal seems to be ruled out. I assume the power supply and distribution board are known to be okay. The one remaining possibility is an incorrectly made power cable — one connector reversed, or shorted (though I think it’d have to be shorted in multiple places, both rails to ground — I don’t think it’s this, though, that shouldn’t cause high current through the resistors.). Is the power cable known to be good?

If so then I’d say we’re down to a short across the rails. You say you checked and it should be easy enough to do but let’s make sure. Use a multimeter and measure the resistance, don’t just use the continuity check. Make sure you’re measuring after the resistors. In fact try checking completely away from the resistors. For instance, what resistance do you measure from one end to the other of the rate pot (both are connected to the rails)? Or between pins 4 and 11 on the TL074 sockets, or 6 and 11 on the LM13700? These all should be the same, but check anyway. Also check between each of those and the ground pins on the power header. I’d do all these with the ICs removed (and power off, of course) and again with the ICs installed. And do this with and without the power cable installed to the power supply (again with power off!) as an additional check on that. And measure resistance in both directions (i.e. switch around the multimeter probes) in case there’s a diode confusing the issue.

Maybe I’m wrong and there’s some way to burn out both resistors without a power reversal or rails short, but I can’t think of any. So let’s make completely sure of those.

7 Likes

Hi everyone, thanks a million for the replies, there is a lot for me to try when I get home.

The unused ground pads are indeed for components that are grounded elsewhere, and the jumper cables are already connected on the board that I received. I’m going to test everything y’all mentioned when I get the chance, and hope for success! Really appreciate your time.

5 Likes

Hi again all,
I’ve been taking some measurements and I’m beginning to wonder if there might be two problems - my selection of diodes, and some other as-yet-undetermined issue. Here are my readings with the multimeter:

All measurements taken AFTER protection resistor
GND to 12V = 420R (neg probe to GND) or 35k with probes reversed
GND to -12V = 577R (neg probe to GND) or 35K with probes reversed
12v to -12v = 135R regardless of polarity

NO CHANGE TO READINGS WITH ICs REMOVED

WITH DIODES REMOVED
GND to 12V = 35k regardless of probe polarity
GND to -12V = 35k regardless of probe polarity
12v to -12v = 142R regardless of polarity

The different readings with probe polarity swapped makes me think the diodes I selected may have been wrong. The fact that resistance went up when I clipped them also maybe suggests this. The BOM calls for a 5V Zener diode, but does not specify a part number. I looked through my collection and found some NZX5V1B diodes, which I figured would do the trick:
Mouser:

Datasheet:
https://www.mouser.com/datasheet/2/916/NZX_SER-1320277.pdf
Apparently I was mistaken, but if these don’t cut the mustard I’m not sure what I’m looking for.

Clipping out the diodes, however, does not change the 140R ish resistance from 12v to -12V. This amount must have been just above the continuity test threshold for my DVM. Currently I have no clue what’s causing it, but I guess I need to continue with the fine tooth comb. Thanks again for all the replies - fingers crossed for an epiphany.

This is hard to understand, the Zeners aren’t supposed to be connected to the power rails. And they’re in series back to back, so the combination should present a high resistance in either direction. But clearly they’re not the problem, or at least not the only problem:

24 V across 142R is a current of 170 mA, and the power to be dissipated is over 4 W, so no surprise your probably 1/4 W resistors burned. no no no… 170 mA through 10R is 290 mW, just a little over 1/4 W. Most of that 4 W would be in the ~120R mystery resistance.

The only components connected across the rails, aside from the ICs, are the 100 nF bypass caps and the rate pot. You might want to try disconnecting those and see what happens. If it’s not one of them then presumably it’s a solder bridge somewhere.

Ought to be fine, I’d think.

4 Likes

I’ve done a fair bit of investigating on this module murder mystery. I figured the rate pot was the most likely culprit, but it turned out to be one of the 100nF bypass caps, as @analogoutput speculated. It must have been defective - it simply measured 120R and when replaced, the weird power shorting was fixed.

Now I’m met with the issue of the whole thing not actually oscillating. The LED’s light up when power is on, but they stay on statically. The direction switch and output attenuator appear to be functioning. I suppose I need to try replacing the ICs and see what happens. I never did bother to match the transistors so I’m really hoping that part isn’t crucial.

The saga continues.

3 Likes

Replacing the ICs has had no effect, I guess it’s time to finally indulge in the dark arts of transistor matching. Best I can tell, the easiest way to do this is with this schematic from Ian Fritz:

I’m too lazy to order a PCB, so I’ll be doing it on stripboard with this not-yet-verified layout I’ve made:


If this layout works, I’ll post it in the verified layout thread. Out of curiosity, does anyone know what sort of diodes are appropriate for this schematic? It’s not explicitly mentioned anywhere, so I’m just gonna use whatever jelly beans I’ve got the most of and hope for the best

The transistors are just part of the exponential CV converter, and a mismatch I think just means it’ll be more temperature sensitive than if they were matched. Definitely wouldn’t affect whether the oscillator works or not.

Here’s a verified one:

Diodes are just 1N4148 or 1N914.

1 Like

Thanks for the insight @analogoutput . That narrows the list of things to check on. It seems that when I manually discharge c7 by bypassing it with a scrap of wire, the LFO ticks forward by one oscillation. I have no idea what this means. I procrastinated on this project by building two MFOS vocoders which are 100x as complicated and came together no problem first try. Go figure.

1 Like

I periodically dust this project off in order to enrage myself. I purchased a capacitance measuring meter specifically for this project - matched the timing caps to 0.1%, still no luck getting it to oscillate. The saga continues.

1 Like