1222 Tuner VCO Module

Almost every datasheet says something like :
LM4040 (Texas Instruments) :
Untitled2
MCP4822 (Microchip) :
Untitled
Do they have the same law specialist ? :stuck_out_tongue:

So yes, the LM4040 may have been damaged by the excessive current…

4 Likes

Alright, I need to get another one in order to build my third oscillator anyway. May as well get a couple of extras to replace the old ones. One of them has started acting up again. Interestingly not the one that had it the worst before.

Good point and from the TI datasheet,

image

with a reverse current of 35mA the 220R resistor definitely pushes it into the no-no zone.

2 Likes

Will have to get mine updated…

I have work in progress to have another 5 Custom Versions of the 1222

1 Like

Funnily enough I had already replaced the 220r resistors for all four vcos with 1k ones as per forum suggestion so that does seem to be the issue at hand. It turned out that I hadn’t switched the octave selector switch to the utmost left position before adding that little non turn washer. I fixed that and the fourth vco all of a sudden started to function just as it should. Now I have 4 vcos the sound just right but only 3 that go up to 4V at the test point the fourth one is still just stuck at roughly 3.3 V Has anybody any other ideas what could be the problem. I would be really thankful

The relevant part of the schematic is:
image
with of course a 1k resistor for R42. Measuring the following points with the other multimeter probe at a ground point should give you:

Left end of R42: 12V
Right end of R42: 4.1V = pin 2 of U4 and pin 3 of RV3
Pin 3 of U4: 0V
Pin 1 of RV3: 0V
Pin 2 of RV3: 4V after trimming = TP1

If you don’t have 4.0V at TP1 then either:

  • You don’t have 12V going in.
  • You do but you don’t have 4.1V on pin 2 of U4 which means that voltage reference is faulty or misconnected
  • You do but you don’t have 4.0V at TP1 which means the trimmer isn’t set right, it is faulty, or it is misconnected

I don’t see any other possibilities.

3 Likes

If your trimmer is 100R 400R instead of 100k you might get something like 3.3V there.

EDIT:corrected bad math.

1 Like

Update: I swapped out the LM4040AIZs on all my oscillators after upping the resistors to 4K7. After testing for a few hours, the wobble is gone for me. On to the next gremlins and maybe some music! :slight_smile:

2 Likes

After a couple of days since I swapped mine, I also have stability again!

2 Likes

Good to know as I’ll start building next week-end.
So up from 220R to 1K to 4K7.

1 Like

I’m sticking with 1K for now, but sure if 4K7 works, why not?

1 Like

I wonder why the 1222 outputs are not terminated with resistors to gain 1k impedance, as the kosmo specs say.
Is this already done by the 3340 IC?

The “spec” is more guidelines than spec, Sam especially is free to do whatever the hell he likes.
We tried to capture what he has been doing in the “spec” wiki so that other designers can have a chance at being compatible.

The 1K output resistor is more for output short circuit protection than for impedance matching.
(1K outputs and 100K inputs are fundamentally mismatched impedances by “spec”, but at audio frequency it doesn’t matter.)

5 Likes

Mismatched for power transfer, indeed, but for voltage transfer you want output ≪ input to maximize the voltage and minimize the current (i.e. bridging, not matching).

(the TL07x’s output stage has an internal resistance of around 200-300 ohm iirc, but the effective output impedance depends on gain)

3 Likes

And as has been discussed elsewhere, a TL07x can survive a short to ground or either rail indefinitely. Still, 100R to 1k output resistors are so common, their absence is a little surprising. You could always add them on the output jacks, of course.

3 Likes

Hello there!

I’ve built a couple of the Kosmo Modules already and they all work great but I’m running into issues wit the VCO. I’ve bought two but have assembled only one so far and it doesn’t work as in: no sound comes from the outputs and the display and LEDs are unresposive.
When I use the Code from SAM the LEDs and Display just stay blank when connected to my power source. When I use the updated Code from Jos Bouten the LEDs just light up constantly and so does the whole display. So at least I know those components are working and I guess the Arduino isn’t the problem as well.

I’ve reflowed every single component as that was a problem with an earlier build I had. I also turned the Potentiometers all they way in every direction (as that was the problem with my LFO build) but to no avail.

I’ve used a multimeter at the test point where it says “4V” but I only get some very small mv number there.

As I’m a beginner when it comes to electronics and haven’t had to troubleshoot anything serious yet I’m a bit stumped and could use some guidance as to what might be wrong / which components I should test and how.

Any help is very much appreciated :sweat_smile:

Thanks!
Ben

1 Like

If you don’t have ~4V at the test point, you can start with this comment a few posts above, replacing “3.3V” by “a few mV”

Until you get that 4V fixed, at best your oscillator will be stuck at the lowest octave setting. You can try feeding some control voltage on the 1V/oct input, to determine if the rest of the oscillator is alive.
You should get at least some very low oscillations (possibly even sub audio).

Until the oscillator works properly in the audio range, there is no point in trying to debug the tuner circuit.

4 Likes

Thank you for your help mate!
I now got my ~4V at the test point but I still can’t get any audio to play. I tried the trimpot “ctrl” (RV6) and also the octave and fine tune knobs but nothing changed at all. If it’s too low of a sound I think I might just not hear anything as I currently only have a very shitty speaker connected to it. What should I test next to see where the problem might lie?

This:

4 Likes

Thanks again for the next steps, but I’m a bit stumped now as to what the hell is going on. Here is what I’ve done:

I’ve changed the Resistor on R42 from a 220R to a 4,7k as recommended in the other thread.

I’ve tested the resistor values from the trimpots to pin 15 and found out that it’s all measuring around 50-60k instead of 100k but I don’t understand why. If I measure the 100k resistors on R23 & R24 I get 55k / 58k
The 100k resistors on R25 & R19 measure the correct 100k
But they’re all from the same batch. Does this mean those two are just faulty? Or does it measure something else with it as they are already on the board (heard something like that a while back but not sure about it)

So now I’m wondering if I should swap out those 2 resistors or the ICs to proceed. Sorry for being kind of high maintenance but I’m really eager to get this thing running. I’ve built 6 other modules (LFO, Mixer, MIDI to CV, Splashback Delay, Filter, Envelope Generator) and they all work fine, but I was really looking forward to finally generate some actual sound with my box -_-

EDIT: Forgot to add: I’ve hooked it up to my audio interface and could confirm that there is zero sound coming out of the module unfortunately