Need some help with the kosmo vco w/ tuner. Please! I’ve lost weeks


So I have built many circuits before, but this is my first synthesizer circuit. I seem to be having what looks like a grounding issue, but I’ll be damned if I can’t find it anywhere. Has anyone seen this kind of issue before (see photo)

? Sometimes it will throw up a letter and the leds below the 7 segment will flicker like crazy, which is why I think it’s a grounding issue. Any suggestions as to where I might quadruple check? I have literally spent over 40 hours troubleshooting this goddamn machine. I bought all the other modules, but will not move on until I finish this one.


Ok, so I suppose it’s only been like 15 hours, but damn. I had it working for about 10 mins, then I left for dinner. When I came back, nothing. Seriously frustrating.


mine did that. There was a bad connection from the arduino to the socket. Aside from the display is everything else working?


Are the segments of the 7 segment display flickering as well? The display will flicker like crazy in the sense that it will flash all segments + leds as part of the start up cycle of the arduino twice, that is assuming you are using the Tune-O-Matic software I worked on. That may happen if the power to the arduino is faltering and you get multiple resets in a row.

1 Like

Hi and thank you for responding!
Is the code yours? Well done!
The arduino is all good and the code is running fine, I believe. The display will sometimes read a note and one of the led’s below will be solid, but one of the side led’s will flicker.

Although, I do get around 3.3 volts on the 5v pin of the arduino, so maybe?

I’ve traced all the components and tested to make sure everything’s grounded. I’m at a total loss. I don’t have a scope, so I cant see whats coming out of the 3340. Do you know if there’s some set voltages that should be coming out of the op amps that I can check?

I was really hoping this would be a common issue, but it doesn’t seem to be the case.

Thank you again for your response and any other insights you may have.


1 Like

Maybe. I’ve checked all the pins for continuity and haven’t found anything loose or not connected. I am, however, reading less than 5v on the 5v pin of the Arduino, but a steady 5 on the vin, so who the hell knows.
Thank you for your response though!

1 Like

No the original code is not mine. But (1) I cleaned it up so that it is easier to maintain and (2) added some testing code which helps when debugging LED connections and (3) added the start up sequence which makes the thing look like it runs on acid :wink: .

I think it is wise to trace the DC supply of the arduino. I do not have a schematic handy, but if that says 5 Volts, then it should be 5 Volts.

The weird thing is that I get 5 on the vin, so the regulator is regulating, but the 5v is less than. I’ll continue to loose sleep.
Thanks again!
Also, I am not using your code. I will, though, if you let me know where to find it. I did kind of chuckle at the code I’m using, if I’m being honest. But god knows I’ve written some rubbish code that does the job.

1 Like

If the regulator is a 7805 or something like that, its input voltage should be higher than 5 volts. Where can I find a circuit diagram?

1 Like

You can find the code here:


1 Like

I found the schematic. The L7805 gets its input voltage from the label TUNERPOWER. That should be connected to +12 volts according to the schematic. What have you connected that to ( and what is its voltage ) ? From the datasheet I derive that its input should be 7 to 20 Volts.

Way past bedtime … later !

1 Like

Yeah, the Arduino’s regulator can’t put out 5V if the input (VIN) is only 5V. As Jos says it needs 7V or more.

The Performance VCO page shows this:

So he’s using an off-board regulator (L7805) with +12V going in and +5V going to the Arduino’s VIN. Which as I understand it is incorrect. If you’re using an external regulator it should go to the +5V pin. Going into VIN it goes to the Arduino’s regulator and it’s not enough for that regulator to put out +5V. But that would explain why you don’t see 5V on the 5V pin. However that’s the way it’s been designed, apparently, so should not account for the problems you’re seeing.

1 Like

I mean, there’s not much that can go wrong here. You’ve measured the voltage at VIN and it’s what the design says it should be. All that’s left are resistors, LEDs, the RAMPOUT signal, and the Arduino itself. I presume you’ve checked resistor values and continuity for all that. You say you have no scope to look at RAMPOUT but it’s the same signal that goes direct to the ramp output jack; does that at least sound okay?

Do you have another Arduino you could try? Unless there’s a problem with RAMPOUT, that’s the only possibility I can think of, that there’s some problem with your Arduino.

1 Like

I often forget how awesome these communities can be.

So I’m not getting any sound out. Nothing. No ramps, triangles, pwms. Nothing. The only sound I hear is the long sigh that I output every time I try plugging it up.


Ah. I think that’s called burying the lede. That’s not the Arduino’s fault; if there’s an Arduino problem it’s secondary to a bigger problem elsewhere.

The ramp, triangle, and square outs all come almost direct from the 3340, through a TL072 or TL074 buffer. It’s kind of unlikely both the TL072 and the TL074 have problems so start by looking at the 3340. Do you have +12V and ground on the correct pins of the 3340? (Pin 16 is +12V and pin 12 is ground.) Also pin 14 should connect to ground through R8 and pin 3 should connect to -12V through R6; are those connections okay? Check from the actual IC pins rather than their solder pads.

I presume you don’t have shorts between the power rails and ground or each other, or you probably would have noticed worse problems, but just in case, have you checked?

Also pins 4, 8, and 10 on the 3340 should connect to pins 3 of the TL072 and pins 10, and 12 of the TL074.


So uh… I gotta be that guy…
Are you sure you plugged into the POWER Connector and not the LINK?
I know my arduino flickered like crazy and I blew an opamp when I plugged it into the link.


Yeah, I’d say that qualifies as “common issue” :upside_down_face: and it’s definitely an easy mistake to make, but did the Arduino power up in your case? (iirc power to link feeds −12V to GND, and other voltages elsewhere, resulting in strange supply rails).

(guess I should go read the schematics again to see what the Arduino might see).

EDIT: So it looks like you’ll get −12 V on circuit GND, +12 V on one TL074 output (saw), and GND on one TL072 output (square) and a couple of 3340 inputs. Depending on how the opamp output stages fail when powered backwards (not going to test that :slight_smile:), you might end up with a weak 12 V or 24 V supply to the 7805, which it can handle.

1 Like

You should see just above −7.4 V on that pin, thanks to the internal zener (a bit higher for the CEM iiuc). I just measured −7.261 V on a board with an AS3340.

Does the code compensate for that by using an internal reference? (the default reference is the 5V supply IIRC)

EDIT: Nevermind, this is only used to sample the pulse wave so guess the reference doesn’t matter that much :slight_smile:

Again, thank you for your response!
I found a few ground pads that were bleeding over to traces they shouldn’t be and resoldered those. So now I am just getting the red dot on the segment screen and still no output. I’ve checked all the pins you suggested and it all checks out.

I am getting ground continuity on pins 1 of the two op amps when the board is powered on. Does that sound right? It doesn’t to me, but what the hell do I know?

Thanks again!