1222 VCO Troubleshooting

I have recently built the 1222 VCO and the Filter GRR in Kosmo Format, and my VCO just isnt acting right. I have been trying to get it to behave for about 3 weeks on and off now and i am completly stumped. Even some of my co workers at my job (Analogue Radio Repair) cant figure it out, so if anyone here could point me in a direction, i would appreciate it more than you can imagine.

The biggest issue for me is the Octave select knob is only working on two octaves. With two of the options being the same (a really high pitch frequency) and the other two options on the knob being semi normal and working.

Also my ±6 Tuner was working about a week ago but it stopped working at some point and i havent been able to figure out why

I would love some general tips on some troubleshooting, seeing as many of you here probly know way more about this module than i do.

I Tried reflowing all the solder joints on the board (all of them…) but i still havent seen any differences.
I also tried swapping out the IC Chips but that hasnt done me any good (I didnt swap out the AS3340 since i only have the one, so that may be the issue but i an hesitant to but another chip if my current one works, ya know?)
I also tried checking the resistors connected to the octave selec knob (R16,R17,R18,R21) but they are all very close to 10k. Maybe the resistors could be closer, but i think even if they were a little off i would still see some movement in the knob when i turned it.
I also tried tuning it many times to resolve some of the issues, but that also hasnt helped out.

Anyone got any ideas?

Here is a video and some pictures of the issues if anyone in interested.

What voltage do you measure at the test point? Does it change when you change the octave switch?

What voltages do you measure at U1 pins 1 and 3 when you turn the octave switch?

1 Like

The Referance test point Voltage is 3.99Volts at all positions on the Octave Switch

Octave Knob Position 1 (leftmost) : U1 Pin1 Voltage = 3.99Volts
Octave Knob Position 2 : U1 Pin1 Voltage = 3.99Volts
Octave Knob Position 3 : U1 Pin1 Voltage = 3.99Volts
Octave Knob Position 4 : U1 Pin1 Voltage = 0Volts
Octave Knob Position 5 (rightmost): U1 Pin1 Voltage = 0Volts

Octave Knob Position 1 (leftmost) : U1 Pin3 Voltage = 3.99Volts
Octave Knob Position 2 : U1 Pin3 Voltage = 3.98Volts
Octave Knob Position 3 : U1 Pin3 Voltage = 3.98Volts
Octave Knob Position 4 : U1 Pin3 Voltage = 0Volts
Octave Knob Position 5 (rightmost): U1 Pin3 Voltage = 0Volts

Thanks for the responce by the way

sounds like the octave switch is wired wrong. check continuity betweend the commom ( ground pin ) and each of the in use outputs.


1 Like

Welcome to the forum :slight_smile:

have you calibrate it ?

1 Like

Pretty likely. Sam shows the wiring here (at 13:33):

1 Like

I just checked and i seem to get contonuity in the individual output pins when i turn the switch to the correct position.

1 Like

Ive tried calibrating it a few times but that hasnt really solved the issue.


When you say leftmost, is that looking at the switch from the front or the back? If from the front then (ignoring pins 2–4) something’s backwards.

Continuity where? There should be no continuity between any pins except from the center pin to the one the switch is turned to.

I can’t see any way the behavior you describe makes sense if the switch is connected and working correctly but maybe there’s something I’m not figuring out.

In fact what you describe sounds like R17 (or maybe R18) is much larger than the other 3, like as if R16, R18, and R21 were 10R instead of 10k, but you say that’s not the case.

The one other thing I can think of is the switch is damaged and there are shorts between some of the outer pins.

With the switch in the 3 (center) position, what are the resistances from the switch pins to ground? (You can measure from the switch pin to the center pins in the 10 pin power header.) And to the test point?

If everything were correct the answers would be:

#1 0 40k
#2 10k 30k
#3 20k 20k = center pin
#4 30k 10k
#5 40k 0


Sorry, i feel like i did a bad job explaining that. I was trying to say that the switch only connects ground to the pin the switch is selected to. As in i believe there arent any sorts in the switch itself.
I did the test you described and there is definetly something going wrong here, i just cant think of what.

From switch ground to Test Point
#1 0
#2 10k
#3 20k
#4 25k
#5 15k

From switch pin to the center pins in power header
#1 15k
#2 25k
#3 35k
#4 10k
#5 0

remove the switch and test from each terminal to ground. rule out the switch first.


I don’t know there’s a connection with you problem, but this place is a bit strange, it looks like the copper is cut

(near the pwm pot)


I believe that trace connects these two pins, and i am getting continuity between them when i test it with my meter


When i removed the switch and checked continuity with my meter, only the GND pin for the switch showed continuity with ground. Is that how it is supposed to be?