Alfa 4 vco help

Hey I need help with a alfa4 vco that I’ve had for a while that now just doesn’t work. Recently it seemed it had problems with the cv input where it would be say on a low F when it was supposed to be on middle C, but when I would fiddle with the cable it would jump to the appropriate note. So I decided to take a look at it and resoldered a few points but plugging it in, instead of outputting saw, triangle, and square waves, it just output a bunch of garbled noise. The knobs don’t seem to do anything and no matter what I do, I have no idea what’s wrong with it as I didn’t damage anything, loose any wire connections, damage it, nothing. Does anyone know why this is?

3 Likes

Maybe a solution here to find your problem

4 Likes

Yeah I literally built a new vco module off the same alfa 4 vco module and its still the exact same problem. I even switched out the as3340 and tl072 chips for others, the same garbled noise. I took out the same chips from another vco off the same stripboard layout that I tested to be working flawlessly, out them in the new circuit, and still the same problem. I even went as far as to put the chips from the dysfunctional circuit and installed them onto the other vco and it works fine. So, no matter what, the chips seem to be fine. But even after building the exact same circuit with the same stripboard layout, even using a different type of stripboard, It is the same problem. It is receiving +12/-12 volts fine, and everything seems to be wired into place. Any suggestions?

1 Like

I would check if there are any unintentional connections between the strips (using a multimeter). I had problems several times with tiny solder bridges between them. I used a knife to really separate the rows and then it worked :wink:

1 Like

also just did that and even used a multimeter to verify that there were no connections where there shouldnt be, has anyone else had this problem?

1 Like

i don’t know ?

The others VCO who works have done with the same stripboard layout ?

what your stripboard layout plz ?
have you pics of your build

1 Like

Sure thing! I’ll include my build photos as well as the stripboard layout I used. You might notice there might be scratches between the traces, that’s because I used an exacto knife to make sure there were no tiny solder connections that either I couldn’t see or were too small to be picked up by the multimeter




3 Likes

Yeah I spent hours trying to figure out what’s wrong with it. I added flux to the joints, added mroe solder, changed the sockets, tried everything and still the same garbled noise. I know all the chips work too. Any other suggestions?

1 Like

Hard with a pic but maybe this points are suspicious for me

maybe also re check your GND wirering

they don’t touch eachothers here (grey and red) ?

a45420af4e313cfb95b9e4cb2db8a821423f5596

3 Likes

Yeah noise in this board sounds like a grounding issue.

2 Likes

Yeah I already checked those points in the red circles, resoldered them and made sure there was no contact and even used a knife again to make sure there were no solder connections between the traces that I couldn’t see and verified it with a voltmeter. I even double checked the ground wiring, everything is fine and the grey and red wires at the bottom aren’t touching at all, all the wiring should be fine. Even using a datasheet on the as3340 and the 2 tl072, the voltages should be fine, it still doesn’t work. What really worries and stumps me is the fact that on the original circuit, I just did some light resoldering and got this problem. Then on the new circuit, using new parts and stripboard, I somehow get the exact same problem. That’s the part that confuses me the most.