8 step sequencer problems, a few questions

I’ve built the 8 step and after fixing a few dumb errors I still have some major problems, hopefully someone with experience can give me a few pointers.

At the moment, I am powering just from the arduino USB, should that be an issue?

When i power up, I am getting the LED for step 8 illuminated, it’s unstable and seems to be more consistent if I am touching a metal part of the pots or panel, which would indicate a grounding issue wouldn’t it? I’ve metered out all the ground points on the jacks and pots and they all connect to gnd above the D2 on the nano.

I can use the forward / back switch, which moves the lit LED across the steps, although it seems to stick at step 5. the LEDs illuminate when the corresponding buttons are pressed, but, for some reason button 8 illuminates LED 7 and vice versa, although the LEDs seem to be connected to the correct pins.

One thing I should add is that the LEDs are built into the buttons and they don’t have polarity, not sure the name of this kind of LED but whichever way you wire it, it lights up so I am guessing any diode functionality is lost, which i imagine may be an issue.

I can post some pics of my build later, but its very over complicated due to my choice of buttons and the fact its on a small panel.

Getting ready to sell my soldering iron and take up knitting…please save me!

1 Like

Are they really LEDs? I guess it’s possible they’re pairs of LEDs, antiparallel, but why would they do that? Anyway, I can’t see how the “diodeness” could matter. You could always stick diodes in series, I guess, if you’re worried about that.

You do have all the “green” wires on the layout diagram connected to Arduino ground, right? Including the one for the LEDs?

When you say “it’s unstable” what do you mean? What behavior do you see?

Assuming you’re following Sam’s version, buttons 7 and 8 are shown as connecting to pins A6 and A7, but in his code it says:

#define STEPBUTTON7   21
#define STEPBUTTON8   20

where 21 and 20 I think are the values corresponding to A7 and A6 respectively, so seemingly inconsistent. If you change 21 to 20 and vice versa in those two lines it should fix that problem.

When you say “it seems to stick at step 5” do you mean the forward switch doesn’t always work when step 5 is lit up? Does the same happen with the backward switch? Have you tried using a clock signal in the forward/backward jacks, does the same happen if you do?


Thanks for the reply, I’ll try clear up those points as best i can…

The LEDs, I’m not sure how they work, the product info doesnt mention anything unusual about them, I presumed they were just normal LED buttons, I did think about putting a diode in line, but with the way its ended up being mounted on veroboard, that would be messy so I was hoping I’d be able to avoid that.

Unstable as in inconsistent behavior, sometimes the LEDs are solid, sometimes they flicker, sometimes the forward switch works, sometimes it doesn’t. I can trigger the step using button 8, but none of the others seem to work in that respect.

I dont have a clock source yet, this is still the very beginning of my build, which is also an issue as so far as i dont really have anything i know works 100% as a starting block. I was hoping this sequencer would be a simple way to get gate to trigger other modules I have been unable to test properly so far.

I’ll see if i can upload a video of it when I get home this evening.

1 Like

Just made the video and it currently seems to work a little better than it did earlier, the keyboard buttons all seem to work now, but cycling through steps is as bad as it was.

I’ve uploaded the video here.

I think you need to put 10k pull down resistors to ground on the switch you are using to move forward and backward if you haven’t. I think pull down resistors on both the forward pin and backward pin of the switch. That fixed this problem for me.

Might be worth doing the same to the 0v and reset switch pins.


There are pulldown resistors (10k to ground) on the Forward/Backward/Reset jacks but they’re between the diodes and the jacks. We had a discussion a while ago and realized the diodes should be between the pulldowns and the jacks. Also there should be a pulldown on the Zero switch. I did that on mine, actually I added a Zero jack with the same resistor-diode-jack configuration. (The switches connect to the jacks so the pulldowns act on the switches too.)

@lookmumnocomputer, can I suggest adding a note about this and the buttons 7&8 issue mentioned above?


Yeah I had same issues before I fixed the pull downs. The arduino is trippin out


oooooh there is hope, I was seriously losing motivation on this whole thing. I’ll look at putting some resistors in there tomorrow. Thanks to everyone!

1 Like

ooh, and the button 7/8 thing could be my fault, I checked the LED was on the right pins, but forgot to check the switches.

1 Like

Don’t need to put in more resistors (except on the Zero switch), just move the ones that are there on the jacks to the other side of the diodes


If you didn’t change the Arduino code, then I think that’s where the problem is


I was going to use your code, but I thought It may be a better idea to follow the original as it’s slightly simpler and has more documentation (although that may not be a good thing…)

I do intend to add your mods later.

for your amusement, here’s the ‘I’ll make it simpler by using veroboard’ design I ended up with…

Gonna look at those pull down resistors now…


OK, so I did the 3 on fwd / back / rst, and…it made no difference at all.

Im gonna do the eurorack power connector part this evening as I wonder if USB power aint giving ground properly.


Nice, much neater than mine


I think adding these pull downs to ground on the switches ended up fixing all my problems, as well as changing the resistors to after the diodes as you pictured above @Kelaifu

1 Like

Those resistors (aside from the one on the Zero) are connected to the same points as the ones on the jacks, after moving to the other side of the diodes.


yeah as analogoutput mentions, I think I have basically done the same thing at the other end of the wire, although I didnt put one on the zero cv. I’ll take another stab at it tomorrow. Thanks for the input

1 Like

just a quick update incase anyone was worried about my sequencer :stuck_out_tongue:

It seems the main issue I was having stems from the switch I was using, although it was brand new, it was some bargain bin junk. I botched another, different style (same function) switch on the same points and the back and forward switching functions perfectly.

I’m not sure I would say the sequencer is working fully, but the issue with the steps is definitely fixed.


Hello Everybody

I figured i would post in this thread instead of starting a new one, as it is regarding problems with the LMNC 8 step sequencer.

I allready made the corrections found in this thread: changed the code, the resistors to diode on FRW, BKW & RST and added the 10K pulldown resistor on Zero CV.

Right now both CV outputs and all the Pots work fine - I can use the the buttons as a keyboard - when i release a button it jumps back to step one…

My problem is that the back and forward switch doesn’t seem to work - i can’t skip between steps. I tried new switches, but that didn’t help.

I was hoping someone more knowledgeable than me, had a good idea about where to start troubleshooting with this behaviour.

Any ideas are most welcome :slight_smile: