1222 Tuner VCO Module

Thanks for the pointer.

Changing the type to cathode works like a charm:

const int LED_DISPLAY_TYPE = COMMON_CATHODE;
5 Likes

Ha, I see this got resolved even before I needed to step in. Nice ! Yes, I included a switch in the software to make it easier to switch between common cathode and common anode some time ago.

At the top of the code I defined 2 constants. Pick the one that fits your hardware and compile and upload it to the nano.

const int COMMON_CATHODE = 1;
const int COMMON_ANODE   = 2;
//
// SET YOUR DISPLAY TYPE HERE
//
const int LED_DISPLAY_TYPE = COMMON_ANODE;

As I am using common anode that is what ended up chosen in the repository.

B.t.w I hope you like the LED test for the display’s segments and other LEDs which is run when the tuner starts up.

6 Likes

Great work. Please can you tell me they sizes of PCB and front panel? I want to make My own VCO 1222 .

Thankyou

1 Like

well the panel is 200mm by 100mm, the pcb not entirely sure but the general rule of thumb would be (using the forums design guidelines) 175mm by 95mm but it’s a split level PCB for the jacks.

2 Likes

Thank You!! This is a great group. !!

3 Likes

Have a look at this thread for specifications: Kosmo Specification

5 Likes

I recently finished my first 1222 VCO, and it is providing sound for all waves, and all knobs seem to be working as intended! I am in the tuning process, but that is where I ran into an issue I cannot figure out. According to Sam his videos, for tuning you need to hook up to the test hole at the back, and turn the REF potentiometer to 4V. However, no matter how much I turn it, I do not get a reading higher than 0.35V. Any ideas would be appreciated!!

1 Like

What’s coming out of the precision regulator?

1 Like

sorry if this is obvious but may aswell check all stops!!! is the ground of the meter connected to a ground? ie a sleeve of a jack for instance?

2 Likes

I hooked up the multimeter to ground of one of the jack sockets, as well as other ground sources. If I turn the REF potentiometer the minimal voltage I read slowly goes up, but it does not go higher than approx. 0.35V (never over 0.4V). And it is not a decimal problem, as I checked this 12V power supply, which reads the voltage as intended.
I find this issue really weird, as everything else seems to work as intended: PWM, sine, saw all work, all knobs work, CNTR and other tuning pot meters work. Only the voltage test output needed to tune the REF pot meter is giving a strange reading.
Any other thoughts? Could it be a bad potentiometer, or should that have resulted in an absence of sound coming out of the VCO? Maybe I should first test the resistance of the REF potentiometer in min/max position to check whether it is working properly?
Thanks in advance for the suggestions!

1 Like

And you defo have a LM4040AIZ ( The AIZ is Crucial ).

1 Like

I looked up the data sheet but it doesn’t say what AIZ means in this context. Any ideas?

(Up to now…) I am under the impression that the LM4040AIZ is a precision voltage regulator valued for 4.096V. I have used this voltage regulator I bought at an electronics store here in the Netherlands:
https://www.okaphone.com/artikel.asp?id=481691, where this data sheet is found: http://ww1.microchip.com/downloads/en/DeviceDoc/21653C.pdf

I am curious to hear whether this swap could be the reason for the issue I am having…

The precision doesn’t really matter, because it’s just used with the trimmer pot to set a +4 V reference. So AIZ versus BIZ isn’t actually important, and presumably if your substitution is wired correctly (differently from the LM4040, it’s not pin compatible) it should work.

3 Likes

@analogoutput: Thanks for your reply! I assumed that the precision voltage regulator I linked had the same pins etc as the LM4040AIZ, and therefore I just soldered it to the PCB as intended for the LM4040AIZ. How should I have wired this replacement substitution?

1 Like

Take a look at the datasheets. From https://www.ti.com/lit/ds/symlink/lm4040-n.pdf the LM4040 is wired like this:
image
and the TO-92 pinout is
image

From http://ww1.microchip.com/downloads/en/DeviceDoc/21653C.pdf the 21653C is wired like this:
image
and the TO-92 pinout is
image

4 Likes

yeah the 4040 is a two wire device in a three wire package.

The substitute is not suitable. ( it could be made to work but would need reconfig, couple of extra components, extra jumper wires, etc )

Rob

2 Likes

Richard,

The AIZ a k a Ted Nugent?

-Fumu / Esopus

It’s clear from the data sheet that the Z in AIZ refers to the package. Z stands for TO-92, M3 for SOT-23, and M7 stands for SC70. The meaning of the other two letters is not so clear.

First letter is tolerance and can be any of A through E. Second letter is temperature grade and can be I or E. Though for 4.1 V the datasheet lists only tolerances A through D (0.1%, 0.2%, 0.5%, and 1%, respectively) and temperature grade I.

3 Likes